H3C交换机恢复出厂和各种基本配置(附下载)

前面我们发布了一些思科交换机配置命令大全,交换机配置案例详解,有不少朋友反映想了解关于H3C的配置命令,本期我们一起来了解下H3C最详细的基础命令

一、不知道密码,如何恢复出厂设置

1、 开机启动,Ctrl+B进入bootrom菜单,选择恢复出厂设置。

2、用com线连上电脑,用超级终端进入,然后重启电脑,看提示按ctrl+b进入bootrom模式,然后按照菜单提示删除flash中的.cfg文件,然后重启就可以了。

 

二、将Trunk端口添加到vlan中

Trunk端口可以允许多个VLAN通过,也就是可以加入多个VLAN,所以Trunk端口的VLAN加入不可能是一个一个地加,而是采取批量添加的方式进行。但只能在以太网端口视图下进行配置,配置步骤如表7-11所示。

【示例1】使用port trunk permit vlan命令将中继端口Ethernet2/0/1加入到2、6、10、50~100 VLAN中。

1. <H3C> system-view  

2. System View: return to User View with Ctrl+Z. 

3. [H3C] interface Ethernet2/0/1 

4. [H3C-Ethernet2/0/1] port trunk permit vlan 2 6 10 50 to 100 

5. Please wait... 

6. Done.  

 

表7-11 把Trunk端口添加到VLAN中的步骤

步骤

命令

用途说明

1

system-view

例如:<sysname> system-view

进入系统视图

2

interface interface-type interface-number

例如:[sysname] interface GigabitEthernet 1/0/1

进入以太网端口视图或端口组视图或二层聚合端口(三者必选其一)。进入以太网端口视图后,下面进行的配置只在当前端口下生效;进入端口组视图后,下面进行的配置将在端口组中的所有端口下生效;在二层聚合端口视图下执行该命令,则该配置将对二层聚合端口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其他成员端口;如果二层聚合端口配置失败,则不会再配置成员端口

port-group { manual port-group-name  | aggregation agg-id }interface bridge-aggregation interface-number命令仅适用于少数支持端口组和二层聚合端口的H3C交换机系列,如S5500S5100S7500E

port-group  { manual port-group-name | aggregation 
 
agg-id }

例如:[Sysname] port-group manual group1

interface  bridge-aggregation interface-number

例如:[Sysname]  interface bridge-aggregation 1

3

port link-type trunk

例如:[sysname- GigabitEthernet1/0/1] port link-
 type trunk

配置端口的链路类型为Trunk类型。交换机二层端口链路默认为Access类型,必须要使用本步命令进行转换,但不能直接在Hybrid端口上使用该命令转换成Trunk链路,而是要先使用port link-type access命令把该链路转换成Access链路,然后再使用本步命令转换成Trunk链路

4

port trunk permit vlan { vlan-id-list | all }

例如:[sysname-GigabitEthernet1/0/1] port  trunk
  permit vlan 
to 10

将以上Trunk端口加入到一个或多个VLAN,以实现允许来自指定VLAN的数据包通过(也就是Cisco IOS中所说的VLAN修剪)

二选一参数vlan-id-list = [ vlan-id1 [ to vlan-id2 ]  ]&<1-10>用于指定Trunk端口允许加入的VLAN的范围,vlan-id取值范围为14094&<1-10>表示前面的参数最多可以重复输入10次,如果是分离VLAN,则各VLAN间用空格分隔

二选一选项all用来指定将以上中继口加入到所有VLAN

默认情况下,所有Trunk端口只允许VLAN 1通过,可以用undo port trunk  permit vlan { vlan-id-list | all }命令将Trunk端口从指定的VLAN中删除。如果多次使用port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-id-list的集合

5

port trunk pvid vlan vlan-id

例如:[sysname-GigabitEthernet1/0/1]port trunk 
 pvid vlan
 10

(可选)设置以上Trunk端口的默认VLAN,参数vlan-id的取值范围为14094。本Trunk端口的默认VLAN ID和相连的对端交换机的Trunk端口的默认VLAN ID必须一致,否则报文将不能正确传输。而且必须设置为非主机所在VLANVLAN ID(通常是设置为VLAN 1,因为VLAN 1是任何端口都默认属于的端口,而且一般不添加主机,仅用于管理用途)。默认情况下,Trunk端口的默认VLANVLAN 1,可以用undo port trunk pvid命令恢复端口的默认VLAN ID,也就是1

【示例2】使用undo port trunk permit vlan命令将中继端口Ethernet2/0/1从VLAN 1中删除。

三、H3C交换机基础配置说明

1、以太网端口的链路类型

Access link:只能允许某一个vlan的untagged数据流通过。

Trunk link:允许多个vlan的tagged数据流和某一个vlan的untagged数据流通过。

Hybrid link:允许多个vlan的tagged数据流和多个vlan的untagged数据流通过。

hybrid link端口可以允许多个vlan的报文发送时不携带标签,而Trunk端口只允许缺省vlan的报文发送时不携带标签。

三种类型的端口可以共存在一台设备上。

2、VLAN配置命令

创建vlan      vlan 100 (1-4094)

删除vlan      undo vlan 100(1-4094)

在vlan中添加端口   portethernet 2/0/1

在vlan中删除端口   undo port ethernet 2/0/1

将端口加入到vlan    port access vlan 100 (1-4094)

将端口脱离vlan      undoport access vlan 100 (1-4094)

显示vlan信息 display vlan VLANID (1-4094)

定义端口为Trunk   port link-type trunk

删除端口的Trunk属性  undo portlink-type

定义端口可以传输的vlan   port trunk permit vlan VLANID

trunk链路允许所有的vlan通过:port trunk permit vlan all

在端口中删除可以传输的vlan:undo port trunk permit vlan VLANID

3、静态路由的配置命令和示例

[H3C]iproute-static ip-address{mask|mask-length} {interface-typeinterface-name|nexthop-address} [perference value] [reject|blackhole]

例如:

ip route-static 129.1.0.0 16 10.0.0.2

ip route-static 129.1.0.0 255.255.0.0 10.0.0.2

ip route-static 129.1.0.0 16 Serial 2/0

四、H3C交换机常用配置命令

1、配置主机名
[H3C]systemname H3C


2、配置console口密码
#进入系统视图。
<H3C> system-view
#进入AUX用户界面视图。
[H3C] user-interface aux 0
#设置通过Console口登录交换机的用户进行Password认证。
[H3C-ui-aux0] authentication-mode password
#设置用户的认证口令为加密方式,口令为123456。
[H3C-ui-aux0] set authentication passwordcipher 123456
#设置从AUX用户界面登录后可以访问的命令级别为2级。
[H3C-ui-aux0] user privilege level 2

3、配置Telnet
#进入系统视图。
<H3C> system-view
#进入VTY0用户界面视图。
[H3C] user-interface vty 0
#设置通过VTY0口登录交换机的用户进行Password认证。
[H3C-ui-vty0] authentication-mode password
#设置用户的认证口令为密码方式,口令为123456。
[H3C-ui-vty0] set authentication passwordcipher 123456
#设置从VTY0用户界面登录后可以访问的命令级别为2级。
[H3C-ui-vty0] user privilege level 2
#设置VTY0用户界面支持Telnet协议。
[H3C-ui-vty0] protocol inbound telnet

4、配置交换机VLAN 1管理地址
<H3C> system-view
[H3C] interface vlan-interface 1
[H3C-VLAN-interface1] ip address192.168.0.129 255.255.255.0

5、配置交换机网关地址
[H3C]ip route-static 0.0.0.00.0.0.0 192.168.0.1

6、配置HTTP服务
[H3C] local-user admin     #创建http用户
[H3C-luser-admin] service-type telnet 
[H3C-luser-admin] authorization-attributelevel 3
[H3C-luser-admin] password cipheradmin  #设置http用户密码,并加密显示

7、配置SNMP
[H3C]snmp-agent
[H3C]snmp-agent community read123456  #设置snmp团体名称,权限为只读
[H3C]snmp-agent sys-info version v1 v2c   #设置snmp版本v1和v2

8、Qos端口限速
[H3C] interface gigabitethernet 1/0/1
#配置限速参数,端口进/出速率限制为5120kbps。
[H3C-GigabitEthernet1/0/1] qos lr inboundcir 5120
[H3C-GigabitEthernet1/0/1] qos lr outboundcir 5120

9、创建VLAN
[H3C] vlan 100

10、删除VLAN
[H3C] undo vlan 100

11、将端口加入vlan 100
[H3C] interface GigabitEthernet 1/0/24
[H3C] port access vlan 100


12、查看VLAN
[H3C]display vlan all

12、查看端口状态
[H3C]display interface GigabitEthernet1/0/24

14、启用端口
[H3C]interface GigabitEthernet 1/0/24
[H3C]undo shutdown

15、关闭端口
[H3C]interface GigabitEthernet 1/0/24
[H3C]shutdown

16、查看MAC地址列表
[H3C]display mac-address

17、查看arp信息
[H3C]display arp

18、查看current配置
[H3C]display current-configuration

19、查看saved配置
[H3C]display saved-configuration
注:current配置是保存在交换机内存里面,当交换机重启时,不会生效
  要交换机重启时生效,必须保存在saved-configureation配置里

20、保存交换机配置
[H3C]save

当然如果你对H3C的交换机配置仍然有诸多不了解,这里面弱电行业网分享一份关于《H3C交换机最详细配置实例手册》,有需要的朋友可以去下载下。

 

下载方式:

苏北小城公众号会话框中输入”H3C配置“即可获取这份图纸的下载地址。

弱电行业

暂无评论

发表评论

您的电子邮件地址不会被公开,必填项已用*标注。

相关推荐

Windows 11 Win10 下载 正式版发布

Windows 11千呼万唤始出来!时光飞逝,老铁们期待的微软Windows 11操作系统官方正式版全新发布。该操作系统具有重大的 ...

5 个不常提及的 HTML 技巧

2021年你需要知道的HTML标签和属性 Web开发人员都在广泛的使用HTML。无论你使用什么框架或者选择哪个后端语言,框架在 ...

udp逆袭!为啥HTTP/3选择了它?

  对网络技术有一定研究的同学一定知道,HTTP/3竟然是基于UDP的。在很多同学的印象里,UDP属于一种非常低级的协议 ...

微信扫一扫,分享到朋友圈

H3C交换机恢复出厂和各种基本配置(附下载)